Jan 162009
 

Sponsored Link

This tutorial will explain How to install ATI fglrx driver in debian.First you need to Download the latest ATI Linux  installer from here
Preparing your system

#apt-get install build-essential linux-headers-$(uname -r) module-assistant

Now you need to Create the .deb packages: (change accordingly depending on which flavor you're running)

# sh ati-driver-installer-8-12-x86.x86_64.run --buildpkg Debian/testing

Install the .deb packages in the current directory

# dpkg -i package.deb

Change to the /usr/src directory

cd /usr/src

Extract the ‘fglrx.tar.bz2′ package:

# tar xjpvf fglrx.tar.bz2

Change to the /usr/src/modules/fglrx directory

cd /usr/src/modules/fglrx

Build the kernel module:

# sh make.sh

Copy the kernel module to the modules directory:

# cp fglrx.ko /lib/modules/2.6.18-4-686/kernel/drivers/char/drm/

Load the "fglrx" module:

# modprobe fglrx

Change the current driver in /etc/X11/xorg.conf to "fglrx"

# vi /etc/X11/xorg.conf

Add the module to /etc/modules to have it start automatically upon boot up:

# vim /etc/modules

Make sure the module loaded smoothly:

dmesg | grep "fglrx"

And, lastly, start GDM as root and make sure everything works.
# gdm

Sponsored Link

 Posted by at 12:59 am

  13 Responses to “How to install ATI fglrx driver in debian”

  1. I use module-assistant to compile and install fglrx kernel module. It lets me to skip the part where I have to extract the tar archive, compile the module and load it manually.

  2. Installing Xorg drivers for nVidia, ATI, Radeon, Intel (and more)

    You can also use sgfxi to move between free and non-free drivers or roll back to native free drivers: Key commands are:

    -n Automatically installs correct native xorg nv, intel, or ati driver for your
    system. Cleans up old binary driver stuff, updates xorg.conf with new driver
    information, and cleans nvidia and fgrlx stuff out of xorg.conf
    -N Force install of specific xorg driver.
    Syntax: sgfxi -N
    Supported Xorg drivers: ati i128 i740 i810 i810-modesetting intel mga
    neomagic nv radeon radeonhd sis tdfx vesa vga voodoo
    Also configures xorg.conf as required. Full radeon xorg 3d configuration
    automatically.
    [/quote]

  3. I installed drivers from Debian non-free method which is described here: http://wiki.cchtml.com/index.php/Debian_Installation_Guide
    basically it is described as this:
    sudo apt-get update
    sudo apt-get install module-assistant fglrx-driver fglrx-kernel-src
    build and install the module
    #:sudo module-assistant auto-install fglrx-kernel-src
    #:sudo aticonfig –initial
    I didnt understand much, but everything is working fine and my Nexuiz is runnin very smooth :)
    but I end up with Debian GNU/Linux, kernel 2.6.26-1-486 in my grub menu, which is now below
    Debian GNU/Linux, kernel 2.6.26-2-686 from my Debian Lenny, so is it safe to just clear kernel 2.6.26-1-486
    from menu or this have some purpose?
    Thx

  4. Hi.

    The “ATI Catalyst™ Display Driver” released in March 26 2009 do not need to kernel sources be downloaded.

    In fact, some conditions applies:

    1) The drivers above support English only.
    2) The display driver requires POSIX shared memory to be enabled on the system.
    3) Kernal Sources package is no longer required if Kernel Header package is installed.
    4) 32-Bit packages must be installed for 64-Bit Linux drivers to install or work.

    Info extracted from: http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.7&product=2.7.4.3.3.3.1&lang=English

    Hope this helps.

    xt4mhz

  5. I just tried this method because I haven’t been able to get anything else to work since Squeeze went to the 2.6.30 kernel. I note that the ait-driver-installer line needs two “-” before buildpkg.

    Also, this step failed with the following errors:
    dpkg-shlibdeps: error: couldn’t find library libc.so.6 needed by debian/fglrx-driver/emul/ia32-linux/usr/lib/libfglrx_pp.so.1.0 (ELF format: ‘elf32-i386′; RPATH: ”).
    Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
    To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
    dh_shlibdeps: dpkg-shlibdeps returned exit code 2
    make: *** [binary] Error 1
    dpkg-buildpackage: error: debian/rules binary gave error exit status 2

    The lack of a libc.so.6 was the problem. After fixing this, I came to another error complaining about fglrx_gamma… I found the solution at http://wiki.cchtml.com/index.php/Ubuntu_Hardy_Installation_Guide#Fix_for_an_error which basically involves extracting the driver then setting a link to the package – the shell script seems to be looking for a misnamed package. After that, the buildpkg worked – leaving me with 4 packages.

    Will keep you posted on whether I got a successful install or not.

  6. No joy in mudville. The fglrx-driver wouldn’t install. The error was relating to overwriting /usr/lib/xorg/modules/extensions/libglx.so. Even removing the existing file and restarting X wouldn’t allow me to get past that point.

    At this point I quit in frustration and just ran the ATI installer. That worked (apparently) and I notice the libglx.so file has been replaced with one installed at the time I was running the ATI installer.

    The screen isn’t flickering the way it did with the vesa driver, so something has changed, but windows are slow to move and don’t go semi-transparent in the process like they used to. Something still needs to be tweaked.

  7. Went back to the vesa driver. The flicker is annoying but not so bad as the slowness of the ATI fglrx driver I’d managed to get installed.

  8. I get this error when trying to build the modules.

    $ sudo sh make.sh
    AMD kernel module generator version 2.1
    doing Makefile based build for kernel 2.6.x and higher
    make.sh: line 412: cd: 2.6.x: No such file or directory
    rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
    make -C /lib/modules/2.6.26-2-686/build SUBDIRS=/usr/src/modules/fglrx modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.26-2-686′
    make[2]: *** No rule to make target `/usr/src/modules/fglrx/firegl_public.c’, needed by `/usr/src/modules/fglrx/firegl_public.o’. Stop.
    make[1]: *** [_module_/usr/src/modules/fglrx] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-2-686′
    make: *** [kmod_build] Error 2
    build failed with return value 2

  9. I got exactly the same as Ryan
    (except the 3rd line said “cd: 421: can’t cd to 2.6.x” and a few words were translated to Swedish).

  10. I can’t run –buildpkg Debian/testing (or anything else Debian/)
    When I run “sh ati-driver-installer-11-2-x86.x86_64.run –buildpkg Debian/testing” I get this error :
    cp: cannot stat `/fglrx-install.T1KijO/x710_64a/*': No such file or directory
    Package build failed!

    This is what it actually fails on:
    cp: cannot stat `./usr/X11R6/lib64/modules/linux': No such file or directory
    dh_install: cp -a ./usr/X11R6/lib64/modules/linux debian/fglrx-driver/usr/lib/xorg/modules/ returned exit code 1

    This is a huge pain – I naively believed that the ATI installer would work (silly me!) – well yeah, it installed a config GUI and so on, but not the fglrx.ko module, so useless.
    Anyone help with this, please, its a nightmare

  11. Further to my comment above, I have now successfully restored the driver.
    The two pre-requisites that one needs that I didn’t have are:
    1) IA32 libs – x64 needs these for the 32-bit component of the driver
    2) Purge the free radeon & ati driver packages before installation

    Once I had done this, the AMD GUI installer worked flawlessly.
    As you can see from my previous comment, I was quite wound up about it – I only solved it because I ran module-assistant, which installed the IA32 libs as a dependency, then I saw some advice to purge the free drivers, & realised my mistake.

  12. how did you “purge” the free drivers? I have exactly the same problem and ia32-libs are already installed. So it must be the free-drivers-problem.

  13. it’s a good idea to purge the free drivers — hunt for them in synaptic package manager with things like nouveau and radeon… and then I think blacklist nouveau in modprobe, forget how I did that but you can look it up on ixquick.com … also I recall that libc.so.6 I think it’s supposed to me in the /usr/lib directory … i created a soft link of a similarly named file ending in 16… it worked to restore my ability to run firefox and some other programs that got harmed by some problem with my failure to remove iceweasel before I hand-installed Firefox.

    What we must remember… the very same ati drivers end up working on ubuntu, and many other distros including deb and rpm based distros. I mean not just working but working great. I’ve spent entire days working on my deb (squeeze, testing and Sid) ati proprietary and all for nothing… I did get it working on one using a non deb kernel but the other machines no luck. I think the problem lies in something to do with the kernels — on debian the nvidias seem to install with no problem. It’s very weird. it could come down to one oddly placed file or missing this or that. Deb is a good distro but we can’t keep wasting our lives it really should be sorted out at the distro team level….but maybe we can all make some progress by looking at things more carefully.

 Leave a Reply

(required)

(required)

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>